Results 1 to 7 of 7

AoE Difficulties

This is a discussion on AoE Difficulties within the Class Questions and Tips forums, part of the Game Questions & Tips category; I have been having this problem for awhile When I am grinding or pvp (drop nova), often I am running ...
Page: 1


  1. #1
    Affenotto
    Guest

    Default AoE Difficulties

    I have been having this problem for awhile

    When I am grinding or pvp (drop nova), often I am running and will want to run cast aoe and run. The problem I am having is that a lot of times when I click to start the cast my char just runs towards the spot (that I clicked) that is within range instead of casting.

  2. #2
    El Gran Tanke Senior Member gimmecookiesnao's Avatar
    Join Date
    Oct 2007
    Posts
    1,175

    Default

    most of times it runs to spot cuz ur outta range.

    or maybe u couble clik..

    my rule of thumb is i try to set drop a nova at head lvl.

    meaning i move nova marker till its at lvl of ur characters head

  3. #3
    Senior Member cizia's Avatar
    Join Date
    Oct 2006
    Location
    Poland
    Posts
    2,929

    Default

    you hold your mouse button too long :P

  4. #4
    outbackrebel
    Guest

    Default

    Yeah it's gotta be a real quick click and your mouse can't move at all.

  5. #5
    Jos
    Guest

    Default

    ye had that problem to when i started with mage
    but like they said above, click fast dont move ya mouse and stay in range.
    keep on practicing and u will learn it someday.
    ones u get a hang of it, its pretty easy

  6. #6
    Senior Member
    Join Date
    Oct 2009
    Posts
    373

    Default

    That was my problem too when I first started a mage. Took me some time to get used to it. Just remember to play mages with "quick clicks and light fingers" on the mouse buttons, or else you will be running into the mob instead of casting. As a paper mage, I must have died over 30 times trying to get the first AOE down.

  7. #7
    Banned
    Join Date
    Jul 2009
    Posts
    257

    Default

    idk i used to hold down the left click too long and it would run in try just tapping it lightly

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •