Page 1 of 2 12 LastLast
Results 1 to 15 of 21

Download Drivers

This is a discussion on Download Drivers within the Tech Support forums, part of the Knight Online (ko4life.com) category; hey, I need to update my drivers, cause i have terrible framelag ingame, but i cant seem to find them. ...
Page: 1


  1. #1
    Promise Less, Do More Senior Member Danny's Avatar
    Join Date
    Oct 2006
    Location
    ישראל - In: New York
    Posts
    3,575

    Default

    hey,

    I need to update my drivers, cause i have terrible framelag ingame, but i cant seem to find them.
    This is my Graphic Card:


    If somebody can give me a Download link i would really appriciate it,
    I've been looking but i cant seem to find it.

    Or if you know an other option to eliminate my framelag please tell me
    greetz

  2. #2
    Call me Ghosty Senior Member SuperGhost's Avatar
    Join Date
    Dec 2006
    Posts
    1,913

    Default

    What OS do you have? Windows XP/Vista?

    btw: I'm guessing you are using laptop if so whats the name of your laptop's manufacturer and product name?( For example Acer Aspire 1350...)

  3. #3
    Senior Member
    Join Date
    Mar 2006
    Location
    Finland
    Posts
    288

  4. #4
    Promise Less, Do More Senior Member Danny's Avatar
    Join Date
    Oct 2006
    Location
    ישראל - In: New York
    Posts
    3,575

    Default

    What OS do you have? Windows XP/Vista?

    btw: I'm guessing you are using laptop if so whats the name of your laptop's manufacturer and product name?( For example Acer Aspire 1350...)[/b]
    Acer Aspire 5100
    When I first bought it, it was on Windows Vista, friend of mine changed it to XP Pro.
    The reason why I posted is cuz I get jumped from 40fps [my max] to 5-10fps, it's been happening ever since that patch which affected graphics and made everything white and even rebooted my computer at times, but now that this patch is fixed, I am still getting insane frame lags, I cant even play the game it's such a piss off.

    @ FusionX, I know that's where I find driver updates, but I cant seem to find the right one for my computer since I changed to XP, and I dont know if I should update it with the Vista driver updates or XP. If it's XP, I cant find such a thing, cuz there isnt... Thats where ko4life tech support comes

  5. #5
    Senior Member
    Join Date
    Mar 2006
    Location
    Finland
    Posts
    288

    Default

    you find it there

    Professional/home -> integrated/motherboard -> Radeon Xpress 1100

  6. #6
    Call me Ghosty Senior Member SuperGhost's Avatar
    Join Date
    Dec 2006
    Posts
    1,913

    Default

    Here is the link

    http://game.amd.com/us-en/drivers_catalyst...p/integrated-xp

    Download Catalyst Software Suite

  7. #7
    Promise Less, Do More Senior Member Danny's Avatar
    Join Date
    Oct 2006
    Location
    ישראל - In: New York
    Posts
    3,575

    Default

    Got it, just gunna download anything there :S
    Hope I get any changes... Ill post in a few minutes.
    edit: restarted computer after updates, logged in ko without reinstalling it, didnt get frame lag for 20 minutes, came back from going afk for a sec, and I saw the fps go down like it used to frame lag on me like usual. im gunna try to reinstall ko 1 more time, if i frame lag, i dunno wtf to do -.-

  8. #8
    Promise Less, Do More Senior Member Danny's Avatar
    Join Date
    Oct 2006
    Location
    ישראל - In: New York
    Posts
    3,575

    Default

    bump? :huh:

  9. #9
    Call me Ghosty Senior Member SuperGhost's Avatar
    Join Date
    Dec 2006
    Posts
    1,913

    Default

    What are the specs of your computer? RAM, Processor ect...

  10. #10
    Promise Less, Do More Senior Member Danny's Avatar
    Join Date
    Oct 2006
    Location
    ישראל - In: New York
    Posts
    3,575

    Default



    h34r:

  11. #11
    Promise Less, Do More Senior Member Danny's Avatar
    Join Date
    Oct 2006
    Location
    ישראל - In: New York
    Posts
    3,575

    Default

    Deleted XTrap folder, didn't work.
    Made a System restore to Jan 1st, graphics were all invisible when I played KO [all was black, couldnt even see login]
    Made reverse system restore back to today, now when I play KO, everything is white and bulky, like that recent patch we had that many people had problems with. Reinstalled KO after that shit, and graphics are normal, but - Result - Still frame lagging...
    /buy_new_graphics_card_and_more_memory, a.q =/

  12. #12
    Call me Ghosty Senior Member SuperGhost's Avatar
    Join Date
    Dec 2006
    Posts
    1,913

    Default

    Deleted XTrap folder, didn't work.
    Made a System restore to Jan 1st, graphics were all invisible when I played KO [all was black, couldnt even see login]
    Made reverse system restore back to today, now when I play KO, everything is white and bulky, like that recent patch we had that many people had problems with. Reinstalled KO after that shit, and graphics are normal, but - Result - Still frame lagging...
    /buy_new_graphics_card_and_more_memory, a.q =/[/b]
    Then I have no idea what your problem might be :S =(

  13. #13
    Promise Less, Do More Senior Member Danny's Avatar
    Join Date
    Oct 2006
    Location
    ישראל - In: New York
    Posts
    3,575

    Default

    Then I have no idea what your problem might be :S =([/b]
    Was afraid you would say that but, whatever.. Shit happens
    thx for the help tho :wub:

  14. #14
    Senior Member bosston's Avatar
    Join Date
    Oct 2006
    Location
    Canada
    Posts
    234

    Default

    download your driver from the list here http://ati.amd.com/support/driver.html
    remember where u save it
    download driver cleaner pro http://downloads.guru3d.com/download.php?det=745
    install driver cleaner pro

    restart computer
    F8 safemode

    run driver cleaner pro
    select multiple cleaning filters, add all the ATI choices
    start

    restart computer

    go back to where u saved the new driver, install it
    restart again

    login ko, waste more time in your life. :P

  15. #15
    Promise Less, Do More Senior Member Danny's Avatar
    Join Date
    Oct 2006
    Location
    ישראל - In: New York
    Posts
    3,575

    Default

    download your driver from the list here http://ati.amd.com/support/driver.html
    remember where u save it
    download driver cleaner pro http://downloads.guru3d.com/download.php?det=745
    install driver cleaner pro

    restart computer
    F8 safemode

    run driver cleaner pro
    select multiple cleaning filters, add all the ATI choices
    start

    restart computer

    go back to where u saved the new driver, install it
    restart again

    login ko, waste more time in your life. :P[/b]
    Still have frame lags.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •