Results 1 to 9 of 9

PUS Hyde's VIB

This is a discussion on PUS Hyde's VIB within the Tech Support forums, part of the Knight Online (ko4life.com) category; Ok so I just purchased 3200 KC for $40.00 so I should have received 3 of Hyde's Virtual Item Bonus ...
Page: 1


  1. #1
    Biaxident
    Guest

    Default PUS Hyde's VIB

    Ok so I just purchased 3200 KC for $40.00 so I should have received 3 of Hyde's Virtual Item Bonus items through letters right? I got my KC but never received the 3 bonus items...Has anyone else encountered this problem yet? I submitted a question on the GamersFirst website so I'm waiting for a reply from them...This is one of my first problems in years so I guess they got rid of Support Tickets? If anyone can help me resolve this issue let me know!

    ~Thanks!

  2. #2
    mr.fox Senior Member henkish's Avatar
    Join Date
    Aug 2007
    Location
    Sweden
    Posts
    623

    Default

    same for all, they will give everyone their items later.. atleast they say they will.

  3. #3
    Biaxident
    Guest

    Default

    Quote Originally Posted by henkish View Post
    same for all, they will give everyone their items later.. atleast they say they will.
    was this recent tho? because just 3 weeks ago my friend bought KC too in order to buy discount premium and he got his items through the mail for every $12.50 he spent...strange =/

  4. #4
    Android Man Senior Member E Mon's Avatar
    Join Date
    Dec 2010
    Location
    Mother of the world
    Posts
    582

    Default

    i think it takes 48 hours to deliver your reward

  5. #5
    Senior Member Rougean's Avatar
    Join Date
    Apr 2008
    Location
    Denmark
    Posts
    1,240

    Default

    It is bugged. You cant get ur items..

    They will give you the items once their "tools" are fixed

  6. #6
    Senior Member
    Join Date
    Mar 2009
    Posts
    74

    Default

    i bought 2k 2 weeks ago and got my items through the mail just fine. bought another 2k last night and didnt receive anything. if im not mistaken i remember them saying on forums that it was bugged and they was gonna fix it but that was like a week and a half ago or so.

  7. #7
    Banned
    Join Date
    Dec 2007
    Posts
    201

    Default

    This might sound wierd buts is BUGGED :O

    they removed all support+forums to so if you are lucky you will get it sometime...

  8. #8
    Member
    Join Date
    Dec 2010
    Posts
    35

    Default

    They didn't remove the forums, What happened was they lost power and the server surged and fried all of their data. Even sword of the age or w/e game is down(so i heard)


    "yes all forums been down since a huge power outage at their data center

    seems the resulting power surge fried the forum server and the sword of the new world game server

    offcourse the game server ig sonna get fixed first followed by the forum server no eta on anything

    "

  9. #9
    roxikcz
    Guest

    Default

    I receiveid it OK 1month before

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •