Results 1 to 8 of 8

So my PC lags like shit with KO

This is a discussion on So my PC lags like shit with KO within the Tech Support forums, part of the Knight Online (ko4life.com) category; i just got a brand new laptop and well the specs are pretty good and it lags alot ing same ...
Page: 1


  1. #1
    Anime Adicted Senior Member Darktuga's Avatar
    Join Date
    Aug 2007
    Posts
    1,094

    Default So my PC lags like shit with KO

    i just got a brand new laptop and well the specs are pretty good and it lags alot ing same it did with my old PC(which was freaking sucky) and its not from the internet cuz it actaully stops not just the people around me (meaning it would b internet)

    using win7

  2. #2
    Zzzzzzzzzzzzz
    Guest

    Default

    Check your drivers.

  3. #3
    Senior Member
    Join Date
    May 2009
    Posts
    433

    Default

    i got the same problem, dont get it either

  4. #4
    Senior Member rambomamboel's Avatar
    Join Date
    Oct 2010
    Location
    Belgium
    Posts
    112

    Default

    yes the last 3days lagging the server verry mutch when the day of the rollback whas the server lagged for 75% of the full day but now is it fixed install ko aggain when you have the problem now to or seeking for the good video card drivers

  5. #5
    Anime Adicted Senior Member Darktuga's Avatar
    Join Date
    Aug 2007
    Posts
    1,094

    Default

    i think it has something to do with win7

  6. #6
    infectedknit
    Guest

    Default

    I'm running Win7 64-bit with KO without any problems. A few things you could check would be these:

    1. AntiVirus. Those things scan and I've noticed it slows down KO tremendously (at least it did when running on my older PC. Newer one this isn't the case)

    2. Make sure you're running it as Admin. I can run launcher, but when you hit start it should bring up the ADministrator Priv. box. MAke sure you're doing that. If it's not coming up, go to your KO folder (Program Files x86, GAmersFirst, Knight Online) and make sure Launcher and KnightOnLine.exe are both by default running as Admin. (right click, properties, compatability, near the bottom check the box run this program as administrator).

    Try those things and see if it helps. I assume this computer can handle the game, right?

  7. #7
    Senior Member
    Join Date
    Nov 2008
    Posts
    195

    Default

    ive got same prob, but only with usko, lags like crazy lol

  8. #8
    Senior Member pa4ned4life's Avatar
    Join Date
    Jan 2011
    Posts
    50

    Default

    Posting up your laptop specifications or model number can help as well.

    Also go to the control panel and performance and maintainance, and under power options change it to max battery.

    Also alot of the time most laptops use integrated video cards so your fps will be extremely low due to that.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •