Page 1 of 2 12 LastLast
Results 1 to 15 of 17

X-Trap Bug with .api extensions

This is a discussion on X-Trap Bug with .api extensions within the Tech Support forums, part of the Knight Online (ko4life.com) category; I couldnt log in cuz xtrap detected some files. I received a message before inputting username/password which says "illegal porgram ...
Page: 1


  1. #1
    Senior Member claude's Avatar
    Join Date
    Apr 2006
    Location
    Italy
    Posts
    366

    Default X-Trap Bug with .api extensions

    I couldnt log in cuz xtrap detected some files. I received a message before inputting username/password which says "illegal porgram detected (apihookcrack)" and then quits the game......zzzzzz

    LOL X-trap sucks; I just looked on pc for *.api files, found some applications used by Acrobat reader, deleted them and magically can log in.......

    zzzzzzzz to K2 zzzzzzzz to X-trap

    Someone should report this to the K2/X-Trap geniuses :lol: in order to have it fixed

  2. #2
    visi
    Guest

    Default

    gay... nothing can replace /ban turks

  3. #3
    h4x0r Admin Devile's Avatar
    Join Date
    Mar 2006
    Posts
    2,545

    Default

    Remember ko4life section is ONLY for ko4life issues. Problems with the forum itself, new features u want, suggestions, etc.

    Moving this to Tech Support.

  4. #4
    priestish
    Guest

    Default

    I was able to do control generation of this error. It is cause by 2 ways. 1) with that API.dll is not loading correctly, 2) it is modify after or before load. Hopefully it is case 1. Such problem is most likely caused by network. XTRAP requires to download a small file with some name api???.dll. If it fails to download this file, then you get the error. XPATCH is the download prograrm, so if you have firewall, let that pass.

    XPATcH uses IE to connect through the internet so if block IE, then you block XPATCH. :-(

  5. #5
    Senior Member claude's Avatar
    Join Date
    Apr 2006
    Location
    Italy
    Posts
    366

    Default

    Originally posted by Devile
    Remember ko4life section is ONLY for ko4life issues. Problems with the forum itself, new features u want, suggestions, etc.

    Moving this to Tech Support.
    sry

  6. #6
    parazit
    Guest

    Default

    can u pls write the names of the applications used by Acrobat reader that u deleted? :unsure:

  7. #7
    h4x0r Admin Devile's Avatar
    Join Date
    Mar 2006
    Posts
    2,545

    Default

    Everytime u load KO, Xpatch.exe downloads these 2 files:

    http://xtrap.knightonlineworld.com/XDataV0.Xtp
    http://xtrap.knightonlineworld.com/XDataFM0.Xtp

    File lists checksums to validate the integrity of the xtrap files in your KO folder. They changed from FTP to HTTP prolly to allow more connections and also block directory listing to avoid fake xtrap servers like it happened with HS FTP server, tho this is not complicated to make anyway. If any of the files listed in the XDataV0.Xtp are missing or different, Xpatch.exe will download them from a different directory.

    If your firewall is blocking these URLs or blocking Xpatch.exe to do its job, u will get some sort of error. I dunno if this is related to this "apihookcrack" error, but might help.

  8. #8
    parazit
    Guest

    Default

    no use
    I can download those files manualy,so it prolly means they're not blocked... Btw i played today and loged out for like an hour and now i tried and... this happened.

    As i see in the xtrap window while its upgrading itself it says : retriving XTrapApi.dll...
    Does this have maybe something to do with it?


  9. #9
    h4x0r Admin Devile's Avatar
    Join Date
    Mar 2006
    Posts
    2,545

    Default

    Delete your Xtrap directory or rename it. Run KO again and let it create the directory and download all the files it needs to run. Depending on the hour of the day, this can take a few seconds or even minutes. Turk time is worst hour to try this since there's thousands of ppl hammering this servers.

    And since K2 has not INVESTED IN A LOAD BALANCER, u could be downloading from a heavy loaded server when others are free.

  10. #10
    parazit
    Guest

    Default

    did,same problem...now it comes even faster,as soon as the animation starts...hm...

    now there are less files in folder



    btw i unistaled acrobat reader and nothing

    maybe its better not to try anymore or they'll block my acc (if they already didnt do it) :unsure: :unsure:

  11. #11
    parazit
    Guest

    Default

    system restored to 2 days ago and everything works :wacko: :wacko:

    system restore FTW

  12. #12
    parazit
    Guest

    Default

    hm...ok next happend now...
    while i was closing proceses in taskmanager,i colsed svhost.exe in network services and after that i tried to log into game,but it said apihookcrack bla bla...so this bug/hack/something could be related to windows integrity... if u ppl have this problem,try restoring system if that doesnt help...try formating/reinstaling window that will/should help in any case -_- <_< -_- <_< or try using some programs that could fix windows (dont rlly know any)

  13. #13
    priestish
    Guest

    Default

    Originally posted by parazit
    hm...ok next happend now...
    while i was closing proceses in taskmanager,i colsed svhost.exe in network services and after that i tried to log into game,but it said apihookcrack bla bla...so this bug/hack/something could be related to windows integrity... if u ppl have this problem,try restoring system if that doesnt help...try formating/reinstaling window that will/should help in any case *-_- *<_< *-_- *<_< *or try using some programs that could fix windows (dont rlly know any)
    Before you do that, try rebooting or restarting windows. svhost is netowrk service provided for windows, it should be running. Restarting windows will restart this service.

  14. #14
    parazit
    Guest

    Default

    i know that,i just meant that if xtrap says api... that it could be that some part of windows isnt working normaly?

  15. #15
    priestish
    Guest

    Default

    Originally posted by parazit
    i know that,i just meant that if xtrap says api... that it could be that some part of windows isnt working normaly?
    Three places that is at fault, XTRAP, Windows, or 3rd party. XTRAP is a lot easier to install and reinstall. I would revert back to older version of KE and have it update everything again. If still not work, reinstall KE. If that fails, reinstall windows.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •